2

Resolved

Not Autofac 3.5 compatible

description

For reasons outside of the scope of this issue, we've been forced to upgrade to Autofac 3.5.0 (that's the NuGet package version). Unfortunately Atlas isn't compatible with this version. This issue covers upgrading to Autofac 3.5.0

comments

amiller wrote Jun 23, 2014 at 3:37 PM

I'll get this fixed ASAP.

Jawvig wrote Jun 23, 2014 at 5:49 PM

That's great, thanks! For the moment I've found that removing the mention of Atlas from the packages.config allows the Autofac upgrade to go ahead, and there don't seem to be any runtime issues once that upgrade is done. I did try using the -IgnoreDependencies flag when performing the "update-package Autofac" but, probably as expected, it didn't ignore dependees' version requirements (as opposed to dependencies).

It ought to be save to allow the dependency to be on <= 4.0, but I know this bit us on a previous minor Autofac version upgrade.

amiller wrote Jun 24, 2014 at 6:31 AM

Updated to support 3.5 - Release here on Codeplex and available on Nuget now.

This version I've decided to cap it at 3.5 for now. I need to check out recent Autofac releases to see what has been changed that was causing clients needing recompiles before I cap it at 4.0. I'll try and update it again shortly. For now, you should be good to go.

If you have any feedback on any desired features for an Atlas 2.0 let me know in the discussions. I've decided its about time to see if I can enhance anything.